阿里云ECS服务器 Linux漏洞一键修复命令 简单实用

  阿里云服务器使用一段时间后,会提示有系统漏洞的问题,大家遇到不要慌张,如果你用阿里云的一件修复的话,他该让你买买买了。

第一种情况

  除了提示带kernel的高危漏洞其他的不需要重启实例即可修复. 有kernel的需要更新完成重启实例.

  修复过程如下:root登陆

  yum check-update 查看可升级的系统软件

  yum upgrade 升级所有可升级的系统软件

  等待执行完成.

第二种情况

出现RHSA的时候,如下图:

阿里云漏洞
阿里云漏洞
 RHSA-2018:3083-重要: 内核 安全和BUG修复更新
RHSA-2017:1931-中危: bash 安全和BUG修复更新
RHSA-2018:1062-重要: 内核 安全和BUG修复更新
RHSA-2018:0151-重要: 内核 安全和BUG修复更新
RHSA-2018:1965-重要: 内核 安全和BUG修复更新
RHSA-2018:0395-重要: 内核 安全和BUG修复更新
RHSA-2018:3665-重要: NetworkManager 安全更新
RHSA-2018:1700-重要: procps-ng 安全更新
RHSA-2018:3032-低危: binutils 安全和BUG修复更新
RHSA-2017:1842-重要: 内核 安全和BUG修复更新
RHSA-2017:2299-中危: NetworkManager 和 libnl3 安全和BUG修复更新
RHSA-2017:2930-重要: 内核 安全和BUG修复更新
RHSA-2018:2748-重要: 内核 安全和BUG修复更新
RHSA-2017:2907-重要: wpa_supplicant 安全更新
RHSA-2019:0049-重要: systemd 安全更新
RHSA-2017:2679-重要: 内核 安全更新
RHSA-2018:0007-重要: 内核 安全更新
RHSA-2018:1318-重要: 内核 安全和BUG修复更新
RHSA-2017:2029-中危: openssh 安全和BUG修复更新 

  修复命令

  使用Root账号登录Shell,键入以下代码回车:

  Centos/Redhat:yum update -y

  Ubuntu:apt-get update -y

  命令完成须重启系统:

  验证修复

  登录阿里云云中心管理控制台,逐个验证修复即可

留下评论